$re = '/^([a-z0-9_\.-]+\@[\da-z\.-]+\.[a-z\.]{2,6})$/m';
$str = 'dash-email@gmail.vn
email.with.dot@google.com.vn
under_score_also_support@yeah.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);