// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z0-9_\.-]+\@[\da-z\.-]+\.[a-z\.]{2,6})$").unwrap();
let string = "dash-email@gmail.vn
email.with.dot@google.com.vn
under_score_also_support@yeah.org";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}