using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*([a-zA-Z]+).*?((\/>)|(>(.*?)<\/\1>))";
string input = @"<button onclick=""startWorker()"">Start <Worker</button>
<p>Start Worker</p>
<img/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}