import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*([a-zA-Z]+).*?((\\/>)|(>(.*?)<\\/\\1>))";
final String string = "<button onclick=\"startWorker()\">Start <Worker</button> \n"
+ "<p>Start Worker</p>\n"
+ "<img/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}