#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*[-_]{2})[a-zA-Z0-9][\xFF01-\xFF5E_-]*[a-zA-Z0-9]$"
Local $sString = " (Not allowed)" & @CRLF & _
"A--Badasd" & @CRLF & _
"A__Bsdasdas" & @CRLF & _
"A-_fdsfdsd" & @CRLF & _
"A_-sfsdfsdf" & @CRLF & _
"" & @CRLF & _
" (allowed)" & @CRLF & _
"A-B-adf" & @CRLF & _
"A_b_adads"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")