const regex = /^(?!.*[-_]{2})[a-zA-Z0-9][\xFF01-\xFF5E_-]*[a-zA-Z0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[-_]{2})[a-zA-Z0-9][\\xFF01-\\xFF5E_-]*[a-zA-Z0-9]$', 'gm')
const str = ` (Not allowed)
A--Badasd
A__Bsdasdas
A-_fdsfdsd
A_-sfsdfsdf
(allowed)
A-B-adf
A_b_adads`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}