const regex = /(?:\G(?!\A)|^\#{4}\s.*:\s*^>.*)\R\K.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|^\\#{4}\\s.*:\\s*^>.*)\\R\\K.+', 'gm')
const str = `#### <u>Author name</u> writes in his 'Title of some Book/Essay/Article':
> First sentence with soft line breaks at the end.
Second sentence.
Third sentence.
Any number of sentences if there are any will follow — all need to be in quote blocks.
<Some other text not belonging to above author comes after empty line>.
`;
const subst = `> $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);