$re = '/(?:\G(?!\A)|^\#{4}\s.*:\s*^>.*)\R\K.+/m';
$str = '#### <u>Author name</u> writes in his \'Title of some Book/Essay/Article\':
> First sentence with soft line breaks at the end.
Second sentence.
Third sentence.
Any number of sentences if there are any will follow — all need to be in quote blocks.
<Some other text not belonging to above author comes after empty line>.
';
$subst = "> $0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;