# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(DMIG[. 0-9A-Z+-\.\*\n]*?)(?=DMIG |\Z)"
test_str = ("DMIG KAAX 0 6 2 0 144\n"
"DMIG* KAAX 559 1\n"
"* 559 1 5.436146121D+04\n"
"DMIG* KAAX 559 2\n"
"* 559 1 2.997528918D+00\n"
"* 559 2 9.038123638D+02\n"
"DMIG* KAAX 559 3\n"
"* 559 1 1.261634118D+01\n"
"* 559 2 5.046148890D+03\n"
"* 559 3 3.415594087D+04\n"
"DMIG* KAAX 559 4\n"
"* 559 1 3.371631556D+01\n"
"* 559 2-3.982366360D+01\n"
"* 559 3-4.056291690D+03\n"
"* 559 4 2.510124955D+04\n"
"DMIG VAX 0 9 2 0 1\n"
"DMIG* VAX 1 0\n"
"* 559 1 1.000000000D+00\n"
"* 559 2 1.000000000D+00\n"
"* 559 3 1.000000000D+00\n"
"* 559 4 1.000000000D+00\n"
"* 559 5 1.000000000D+00\n"
"* 559 6 1.000000000D+00\n"
"* 563 1 1.000000000D+00\n"
"* 563 2 1.000000000D+00\n"
"* 563 3 1.000000000D+00\n"
"* 563 4 1.000000000D+00\n"
"* 563 5 1.000000000D+00\n"
"DMIG PAX 0 9 2 0 1\n"
"DMIG* PAX 1 0\n"
"* 559 1 5.588391601D+01\n"
"* 559 2 1.168264164D+00\n"
"* 559 3 1.009317748D+01\n"
"* 559 4-1.081129573D+01\n"
"* 559 5-4.022276625D-01\n"
"* 559 6-8.447832210D-01\n"
"* 563 1 5.591312663D+01\n"
"* 563 2-6.528280697D+00\n"
"* 563 3-7.816536324D+00\n"
"* 563 4 1.078904913D+01\n"
"* 563 5-3.358274028D-01\n"
"* 563 6-8.739271547D-01")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.