import Foundation
let pattern = #"(DMIG[. 0-9A-Z+-\.\*\n]*?)(?=DMIG |\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DMIG KAAX 0 6 2 0 144
DMIG* KAAX 559 1
* 559 1 5.436146121D+04
DMIG* KAAX 559 2
* 559 1 2.997528918D+00
* 559 2 9.038123638D+02
DMIG* KAAX 559 3
* 559 1 1.261634118D+01
* 559 2 5.046148890D+03
* 559 3 3.415594087D+04
DMIG* KAAX 559 4
* 559 1 3.371631556D+01
* 559 2-3.982366360D+01
* 559 3-4.056291690D+03
* 559 4 2.510124955D+04
DMIG VAX 0 9 2 0 1
DMIG* VAX 1 0
* 559 1 1.000000000D+00
* 559 2 1.000000000D+00
* 559 3 1.000000000D+00
* 559 4 1.000000000D+00
* 559 5 1.000000000D+00
* 559 6 1.000000000D+00
* 563 1 1.000000000D+00
* 563 2 1.000000000D+00
* 563 3 1.000000000D+00
* 563 4 1.000000000D+00
* 563 5 1.000000000D+00
DMIG PAX 0 9 2 0 1
DMIG* PAX 1 0
* 559 1 5.588391601D+01
* 559 2 1.168264164D+00
* 559 3 1.009317748D+01
* 559 4-1.081129573D+01
* 559 5-4.022276625D-01
* 559 6-8.447832210D-01
* 563 1 5.591312663D+01
* 563 2-6.528280697D+00
* 563 3-7.816536324D+00
* 563 4 1.078904913D+01
* 563 5-3.358274028D-01
* 563 6-8.739271547D-01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)