package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z0-9]+\.)+([A-Za-z0-9]{2,})`)
var str = `Just because the.com heheyahoo.com weather is starting to get warm, does not mean that you should look sloppy. Get inspired and check out our collection of men's summer outfits. famousoutfits
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}