re = /([A-Za-z0-9]+\.)+([A-Za-z0-9]{2,})/m
str = 'Just because the.com heheyahoo.com weather is starting to get warm, does not mean that you should look sloppy. Get inspired and check out our collection of men\'s summer outfits. famousoutfits
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end