using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[1-2]\d\d\d-[0-1]\d-[0-3][\d]";
string input = @"2009-12-31";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}