$re = '/[1-2]\d\d\d-[0-1]\d-[0-3][\d]/';
$str = '2009-12-31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);