$re = '/\b[A-Z](?=([&.]?))(?:\1[A-Z])+\b/m';
$str = 'My name is STEVE. My friend works at (I.A.). Indian Army(IA). B&W also B&&W Also I...A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);