re = /\b[A-Z](?=([&.]?))(?:\1[A-Z])+\b/m
str = 'My name is STEVE. My friend works at (I.A.). Indian Army(IA). B&W also B&&W Also I...A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end