package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*[x.][x.\s]*`)
var str = `total 19xx.100
total 19x..100
total 19..100
total 19x .100`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}