use strict;
my $str = 'total 19xx.100
total 19x..100
total 19..100
total 19x .100';
my $regex = qr/\s*[x.][x.\s]*/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";