using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Z][0-9]{6})\s([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6})\s([0-9]{4})\s([a-z]*\/)";
string input = @"I220430 05:12:06.367747 2604 sql/exec_log.go:188 [n1,client=127.0.0.1:40190,hostnossl,user=root] 2 exec ""$ cockroach sql"" {""imperva""[52]:READWRITE} ""INSERT INTO imperva(ice_cream, ramen, pizza) VALUES ('mister', 'motomachi', 'pizzeria farina')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}