$re = '/(domain.com|domain1.com)/';
$str = 'domain.com
domain1.com
ci.domain1.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);