#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:^(\w{1,255}):(.{1,255})@|^)(?:(?:(?=.{0,253}($|:))((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+(?:[a-z0-9]{1,63})))|localhost)(:\d{1,5})?"
Local $sString = "1234567890123456789012345678901234567890" & @CRLF & _
"cabcabcabcabcabcabcabcabcabcabcabcabc" & @CRLF & _
"localhost" & @CRLF & _
"user:password@localhost:80" & @CRLF & _
"hgfhd456450-34.5655647.cabcabcabcabcabcabcabcabcabcabcabcabc" & @CRLF & _
"hgfhd456450-34-.5655647.cabcabcabcabcabcabcabcabcabcabcabcabc" & @CRLF & _
"10.10.0.1" & @CRLF & _
"192.168.0.1" & @CRLF & _
"test.com" & @CRLF & _
"test-test.com" & @CRLF & _
"test.com/path/to/page?var=1&var2=2" & @CRLF & _
"test.com:80" & @CRLF & _
"user:password@test.com" & @CRLF & _
"user:password@test-test.com" & @CRLF & _
"user:password@test.com/path/to/page" & @CRLF & _
"user:password@test.com/path/to/page?var=1&var2=2" & @CRLF & _
"user:password@test.com:80" & @CRLF & _
"" & @CRLF & _
"user:password@aaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaa.com:8080" & @CRLF & _
"www.test.com" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.com" & @CRLF & _
"user:password@aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")