import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(\\w{1,255}):(.{1,255})@|^)(?:(?:(?=.{0,253}($|:))((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\\.)+(?:[a-z0-9]{1,63})))|localhost)(:\\d{1,5})?";
final String string = "1234567890123456789012345678901234567890\n"
+ "cabcabcabcabcabcabcabcabcabcabcabcabc\n"
+ "localhost\n"
+ "user:password@localhost:80\n"
+ "hgfhd456450-34.5655647.cabcabcabcabcabcabcabcabcabcabcabcabc\n"
+ "hgfhd456450-34-.5655647.cabcabcabcabcabcabcabcabcabcabcabcabc\n"
+ "10.10.0.1\n"
+ "192.168.0.1\n"
+ "test.com\n"
+ "test-test.com\n"
+ "test.com/path/to/page?var=1&var2=2\n"
+ "test.com:80\n"
+ "user:password@test.com\n"
+ "user:password@test-test.com\n"
+ "user:password@test.com/path/to/page\n"
+ "user:password@test.com/path/to/page?var=1&var2=2\n"
+ "user:password@test.com:80\n\n"
+ "user:password@aaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaa.com:8080\n"
+ "www.test.com\n"
+ "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.com\n"
+ "user:password@aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}