$re = '/cyberpunk[\W_]*+Programmers?[\W_]*+net/m';
$str = 'cyberpunk @ programmer . net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);