re = /cyberpunk[\W_]*+Programmers?[\W_]*+net/m
str = 'cyberpunk @ programmer . net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end