import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "matei 140 for ";
final String string = "<?php\n"
+ "$days = 7; // Eine Woche\n"
+ "$activity = \"Laufen\"; // Trainingsart\n"
+ "$duration = 30; // Minuten pro Tag\n"
+ "for ($day = 1; $day <= $days; $day++) {\n"
+ " echo \"Am Tag $day bist du $duration Minuten $activity gewesen.<br>\";\n"
+ "}\n\n"
+ "$activities = [\"Laufen\", \"Schwimmen\", \"Radfahren\", \"Yoga\", \"Krafttraining\"];\n"
+ "$motivation = 5; // Skala 1-10\n"
+ "$goal = \"fit werden\"; // Ziel\n"
+ "$duration = 30; // Minuten pro Tag\n"
+ "$days = 7; // Eine Woche\n"
+ "for ($day = 1; $day <= $days; $day++) {\n"
+ " $activity = $activities[($day-1)%count($activities)];\n"
+ " echo \"<br>Tag $day: Heute machst du $duration Minuten $activity, Motivation: $motivation/10, Ziel: $goal.\";\n"
+ " $motivation++;\n\n"
+ " if($day == $days){\n"
+ " echo \"<br>\";\n"
+ "}\n"
+ "}\n\n\n"
+ "function wochenplan($activities, $days, $dauerProTag) {\n"
+ " $gesamt = 0;\n"
+ " for ($i = 1; $i <= $days; $i++) {\n"
+ " $activity = $activities[array_rand($activities)];\n"
+ " echo \"<br> Tag $i: $activity für $dauerProTag Minuten.\";\n"
+ " $gesamt += $dauerProTag;\n"
+ " if($i == $days){\n"
+ " echo \"<br><br>\";\n"
+ " }\n"
+ " }\n"
+ " return $gesamt;\n"
+ "}\n"
+ "$activities = [\"Laufen\", \"Schwimmen\", \"Radfahren\", \"Yoga\", \"Krafttraining\"];\n"
+ "$gesamt = wochenplan($activities, 7, 30);\n"
+ "echo \"Gesamtzeit: $gesamt Minuten.\";\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}