import Foundation
let pattern = #"matei 140 for "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<?php
$days = 7; // Eine Woche
$activity = "Laufen"; // Trainingsart
$duration = 30; // Minuten pro Tag
for ($day = 1; $day <= $days; $day++) {
echo "Am Tag $day bist du $duration Minuten $activity gewesen.<br>";
}
$activities = ["Laufen", "Schwimmen", "Radfahren", "Yoga", "Krafttraining"];
$motivation = 5; // Skala 1-10
$goal = "fit werden"; // Ziel
$duration = 30; // Minuten pro Tag
$days = 7; // Eine Woche
for ($day = 1; $day <= $days; $day++) {
$activity = $activities[($day-1)%count($activities)];
echo "<br>Tag $day: Heute machst du $duration Minuten $activity, Motivation: $motivation/10, Ziel: $goal.";
$motivation++;
if($day == $days){
echo "<br>";
}
}
function wochenplan($activities, $days, $dauerProTag) {
$gesamt = 0;
for ($i = 1; $i <= $days; $i++) {
$activity = $activities[array_rand($activities)];
echo "<br> Tag $i: $activity für $dauerProTag Minuten.";
$gesamt += $dauerProTag;
if($i == $days){
echo "<br><br>";
}
}
return $gesamt;
}
$activities = ["Laufen", "Schwimmen", "Radfahren", "Yoga", "Krafttraining"];
$gesamt = wochenplan($activities, 7, 30);
echo "Gesamtzeit: $gesamt Minuten.";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)