using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=。)(?=\b\d{1,2}[日月])";
string input = @"ZZZ。10月,AAA。11月2日,BBB。CCC。3日,DDD。EEE。12月,FFF
ZZZZZ,10月,AAA。BBB。CCC。";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}