const regex = new RegExp('(?<=。)(?=\\b\\d{1,2}[日月])', 'gm')
const str = `ZZZ。10月,AAA。11月2日,BBB。CCC。3日,DDD。EEE。12月,FFF
ZZZZZ,10月,AAA。BBB。CCC。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}