$re = '/^\s*|\s*,\s*(?!\s+$)|(?<![\s,])\s*,?\s*$/m';
$str = 'foo
foo , bar
foo, bar, no match,
foo , bar
foo ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);