re = /^\s*|\s*,\s*(?!\s+$)|(?<![\s,])\s*,?\s*$/m
str = 'foo
foo , bar
foo, bar, no match,
foo , bar
foo '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end