import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?>(?:(?:[^\"\\n;]*\"[^\"\\n]*\")+(?!\"))?[^\"\\n;]*)\"?[^\"\\n;]*);.*";
final String string = "Peekaboo ; A comment starts with a semicolon and continues till the EOL\n"
+ "Unless the semicolon is surrounded by dquotes \"Don’t do it ; here\" ;but match me; once\n"
+ "Im not surrounded \"so pay attention to me\" ; \"peekaboo\"\n"
+ "Im not surrounded \"so pay attention\" to;me\" ; \"peekaboo\"\n"
+ "Im not surrounded \"so pay attention to me ; peekaboo\n"
+ "Dquote escapes a dquote so \"dont pay attention to \"\"me;here\"\" buster\" do it ; here\n"
+ "Don’t pay attention to \"\"\"me;here\"\"\" but do \"\"it;here\"\" \n"
+ "and \"dont do \"\"it;here\"\"\" either ;peekaboo\n"
+ "but \"pay attention to \"it;here\"\" ;not here though\n"
+ "Simon said \"I like goats\" then he added \"and sheep;\" ;a good comment is \"here\n"
+ "Simon said \"I like goats\" then he added \"and sheep;\" dont do it here\n"
+ "Simon said \"\"I like goats;\"peekaboo\n"
+ "Simon said \"I like goats;\"\"peekaboo\n\n"
+ "\"\"I like goats;\"peekaboo\n"
+ "\"I like goats;\"\"peekaboo\n\n"
+ "\"aaa ; bb\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}