import Foundation
let pattern = #"^((?>(?:(?:[^"\n;]*"[^"\n]*")+(?!"))?[^"\n;]*)"?[^"\n;]*);.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Peekaboo ; A comment starts with a semicolon and continues till the EOL
Unless the semicolon is surrounded by dquotes "Don’t do it ; here" ;but match me; once
Im not surrounded "so pay attention to me" ; "peekaboo"
Im not surrounded "so pay attention" to;me" ; "peekaboo"
Im not surrounded "so pay attention to me ; peekaboo
Dquote escapes a dquote so "dont pay attention to ""me;here"" buster" do it ; here
Don’t pay attention to """me;here""" but do ""it;here""
and "dont do ""it;here""" either ;peekaboo
but "pay attention to "it;here"" ;not here though
Simon said "I like goats" then he added "and sheep;" ;a good comment is "here
Simon said "I like goats" then he added "and sheep;" dont do it here
Simon said ""I like goats;"peekaboo
Simon said "I like goats;""peekaboo
""I like goats;"peekaboo
"I like goats;""peekaboo
"aaa ; bb"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)