using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$€£]?(?:(?<!\w)-)?\d+[\d,.]*\b";
string input = @"AAA PCSK-9, $111 -3,33";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}