$re = '/[$€£]?(?:(?<!\w)-)?\d+[\d,.]*\b/m';
$str = 'AAA PCSK-9, $111 -3,33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);