#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https:\/\/)?(www\.)?(meetup\.com\/){1}[A-Za-z0-9-]{5,60}(\/events\/){1}[A-Za-z0-9-]+(\/)?$"
Local $sString = "example" & @CRLF & _
"http://example" & @CRLF & _
"https://www.example.com" & @CRLF & _
"http:/example.com" & @CRLF & _
"example.reallylongtld" & @CRLF & _
"https://example.com" & @CRLF & _
"https://ww.example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"https://www.meetup.com/" & @CRLF & _
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/" & @CRLF & _
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/" & @CRLF & _
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399" & @CRLF & _
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/" & @CRLF & _
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/" & @CRLF & _
"www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/" & @CRLF & _
"www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399" & @CRLF & _
"meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399" & @CRLF & _
"meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/" & @CRLF & _
"https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")