import re
regex = re.compile(r"^(https:\/\/)?(www\.)?(meetup\.com\/){1}[A-Za-z0-9-]{5,60}(\/events\/){1}[A-Za-z0-9-]+(\/)?$", flags=re.MULTILINE)
test_str = ("example\n"
"http://example\n"
"https://www.example.com\n"
"http:/example.com\n"
"example.reallylongtld\n"
"https://example.com\n"
"https://ww.example.com\n"
"https://www.example.com\n"
"https://www.meetup.com/\n"
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/\n"
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/\n"
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
"https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/\n"
"www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
"www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
"meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
"meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
"https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")