$re = '/(?i)^.*?\K(?<!\S)[b-z]*a[a-z]*(?!\S)/m';
$str = 'The cat ate the dog
and the mouse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);