re = /(?i)^.*?\K(?<!\S)[b-z]*a[a-z]*(?!\S)/m
str = 'The cat ate the dog
and the mouse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end