using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:.*?\.){2}.*?)\.";
string substitution = @"$1 (ЗАМЕНА)";
string input = @"Пример. Пример. Пример. Пример. Пример. Пример. Пример.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}