package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(*UCP)\b42\b`)
var str = `42
hello 42
hello-42-
été42
042
4 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}