import re
regex = re.compile(r"(*UCP)\b42\b")
test_str = ("42\n"
"hello 42\n"
"hello-42-\n\n"
"été42 \n"
"042\n"
" 4 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")