#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{\d+\}$[\r\n]+([\s\S]+?)^\)$"
Local $sString = "* 1 FETCH (UID 2 BODY[] {7765}" & @CRLF & _
"data to be extracted" & @CRLF & _
"from here!" & @CRLF & _
")" & @CRLF & _
"* 2 FETCH (UID 3 BODY[] {443}" & @CRLF & _
"data to be extracted" & @CRLF & _
"from here!" & @CRLF & _
")" & @CRLF & _
"* 3 FETCH (UID 4 BODY[] {4432}" & @CRLF & _
"data to be extracted" & @CRLF & _
"from here!" & @CRLF & _
")" & @CRLF & _
"* 4 FETCH (UID 5 BODY[] {123}" & @CRLF & _
"data to be extracted" & @CRLF & _
"from here!" & @CRLF & _
")" & @CRLF & _
"SS01 OK Success"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")