re = /\{\d+\}$[\r\n]+([\s\S]+?)^\)$/m
str = '* 1 FETCH (UID 2 BODY[] {7765}
data to be extracted
from here!
)
* 2 FETCH (UID 3 BODY[] {443}
data to be extracted
from here!
)
* 3 FETCH (UID 4 BODY[] {4432}
data to be extracted
from here!
)
* 4 FETCH (UID 5 BODY[] {123}
data to be extracted
from here!
)
SS01 OK Success'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end