const regex = /^'(.* \d{10,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\'(.* \\d{10,})', 'gm')
const str = `'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001',
'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001',
'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001',
'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001',`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}