import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bclass \\w+\\s*\\{\\s*|\\G(?!\\A)\\s*(?:(?://|#).*$|/\\*[\\s\\S]*?\\*/|\\bconst[^;]*;)\\s*)\\K(\\$\\w+\\s*(?:;|=.*;))";
final String string = "class MyClass {\n"
+ " $myvar1;\n"
+ "// some comment here (even with a variable $x;)\n"
+ " $myvar2;\n"
+ "/* I have a multiline comment here\n\n"
+ "with a variable $x; here\n"
+ "*/\n"
+ " $myvar3;\n"
+ "# Just another comment $x;\n"
+ " $myvar4;\n"
+ " const SOMETHING;\n"
+ " $myvar5;\n\n\n"
+ " function __construct($myvar1 = NULL, $myvar2 = array()) {\n"
+ " $this->myvar1 = $myvar1; \n"
+ " $this->myvar2 = $myvar2; \n"
+ " }\n"
+ "}";
final String subst = "private $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}