# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\bclass \w+\s*{\s*|\G(?!\A)\s*(?:(?://|#).*$|/\*[\s\S]*?\*/|\bconst[^;]*;)\s*)\K(\$\w+\s*(?:;|=.*;))"
test_str = ("class MyClass {\n"
" $myvar1;\n"
"// some comment here (even with a variable $x;)\n"
" $myvar2;\n"
"/* I have a multiline comment here\n\n"
"with a variable $x; here\n"
"*/\n"
" $myvar3;\n"
"# Just another comment $x;\n"
" $myvar4;\n"
" const SOMETHING;\n"
" $myvar5;\n\n\n"
" function __construct($myvar1 = NULL, $myvar2 = array()) {\n"
" $this->myvar1 = $myvar1; \n"
" $this->myvar2 = $myvar2; \n"
" }\n"
"}")
subst = "private $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.