package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){([^}]*)}`)
var str = `{Billion is|Millions are|Trillion is} {an extremely |a| a generously | a very} { tiny|little |smallish |short |small} stage in a vast {galactic| |large|huge|tense|big |cosmic} {universe|Colosseum|planet|arena}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}