re = /{([^}]*)}/m
str = '{Billion is|Millions are|Trillion is} {an extremely |a| a generously | a very} { tiny|little |smallish |short |small} stage in a vast {galactic| |large|huge|tense|big |cosmic} {universe|Colosseum|planet|arena}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end