$re = '/(?:^[A-Za-z].*\R\K|(?!^)\G)(?=(?:[A-Za-z].*\R)*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}\b)/m';
$str = 'Xbo
Play
Sep2018
/////////////////////////
reregg
95959
1151
Zbo
Tlay
Jul2018';
$subst = "0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;