package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(.*):(\d+):(\d+): (.*):\s*(.*)$`)
var str = `../GeneratedModel/PortController.cpp:118:37: Warnung: Variable »params« wird nicht verwendet [-Wunused-variable]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}